iPod touch iOS 4.2.1

Masalah utama dari pemilik iDevice yang sudah tidak lagi mendukung iOS versi terbaru adalah ketersediaan aplikasi yang semakin sedikit. Mau install aplikasi di iPad, eh ternyata aplikasinya mengharuskan versi iOS minimal versi 6.0. iPadnya mau diupdate, tapi sayangnya iOS 5.1.1 sudah paling terbaru, terpaksa harus ikhlas dengan aplikasi yang itu-itu saja.

Tapi sekarang itu bukan masalah lagi. Karena App Store kini mengijinkan kita untuk mendownload aplikasi yang kompatibel untuk iDevice Anda jika versi terbarunya tidak kompatibel dengan iDevice Anda saat ini. Contohnya, aplikasi YouTube yang terbaru hanya untuk iOS 6.0 ke atas saja, otomatis aplikasinya tidak akan bisa diinstall di iPad yang maksimal hanya sampai iOS 5.1.1. Nah, sekarang, kalau Anda mencobanya menginstall YouTube dari App Store, maka App Store akan merekomendasikan Anda untuk mendownload versi sebelumnya yang masih cocok untuk iOS 5.1.1.

Catatan:
Anda bisa saja mendownload versi lama dari sebuah aplikasi di App Store yang kompatibel dengan versi iOS di iDevice Anda, tapi tidak ada jaminan kalau aplikasi tersebut masih bekerja dengan normal setelah diinstall. Sebagai Contoh, aplikasi WhatsApp setahu saya yang masih kompatibel dengan iOS 4.2.1 adalah versi 2.8.4, namun, meskipun WhatsApp-nya berhasil terinstall Anda tetap tidak bisa menggunakannya karena server aktivasi WhatsApp menolak versi 2.8.4 ke bawah.

Good luck!

Baca juga: Cara install aplikasi yang kompatibel untuk iOS/iDevice tua.

Via:
[Reddit]